Forum Użytkowników
Programów LeftHand


 
Poprzedni temat :: Następny temat
Problem z firebirdem w czasie instalacji
Autor Wiadomość
dsolow

Dołączył: 11 Maj 2010
Posty: 1
Skąd: Warszawa
Wysłany: 2010-05-12, 00:39   Problem z firebirdem w czasie instalacji

Próbuje zainstalować program na Ubuntu 9.10 i w trakcie instalacji Firebirda w wersji 1.5.4 pojawia się komunikat o tym że "script .......... missing LSB tags and overrides. The script you are attempting to invoke has been converted to an Upstart job, but 1sb-header is not supported for Upstarts job". Na koniec install.sh zawiadamia że "can not start server". Próby /etc/init.d/firebird reload kończą się tym samym komunikatem. Wszelkie inne wersje servera sprawdziłem i odinstalowałem. Jak jednak ruszyć z instalacją w tym przypadku?
 
   
Mariusz Gonera 
Kierownik projektów


Pomógł: 1 raz
Wiek: 38
Dołączył: 21 Gru 2006
Posty: 83
Skąd: POLSKA
Wysłany: 2010-05-14, 07:19   Re: Problem z firebirdem w czasie instalacji

dsolow napisał/a:
Próbuje zainstalować program na Ubuntu 9.10 i w trakcie instalacji Firebirda w wersji 1.5.4 pojawia się komunikat o tym że "script .......... missing LSB tags and overrides. The script you are attempting to invoke has been converted to an Upstart job, but 1sb-header is not supported for Upstarts job". Na koniec install.sh zawiadamia że "can not start server". Próby /etc/init.d/firebird reload kończą się tym samym komunikatem. Wszelkie inne wersje servera sprawdziłem i odinstalowałem. Jak jednak ruszyć z instalacją w tym przypadku?


Proszę spróbować postąpić zgodnie z opisem dostępnym na naszym FAQ pod linkiem:

http://www.lefthand.com.pl/pl/subsites/FAQ/#q38

W razie dalszych problemów proszę o bezpośredni kontakt na adres 'support@lefthand.com.pl'.
_________________
Biuro rachunkowe ząbki
 
   
wojt 

Dołączył: 12 Lut 2010
Posty: 1
Skąd: Jaworzno
Wysłany: 2010-07-19, 21:24   Ubuntu 10.04 64bit

Problemem może być 64bitowa wersja systemu Linux. Poniżej zamieszczam list wysłany do Lefthand z opisem moich problemów. Przy próbie odpalenia firebird-a dostarczonego z LHFK też miałem podobny komunikat. Po analizie okazało się, że pomimo zainstalowania dodatkowych bibliotek 32 bitowych, nadal są problemy z linkowanie bibliotek.

-------------------------------------------------
Szanowni Państwo,
niestety dołączony przez Was Firebird nie działa na 64bitowym Ubuntu
10.04 (sam program działa, bez zarzutu). Zainstalowałem dostarczany
przez Ubuntu Firebird 2.1 i nawet udało mi się przenieść bazy danych
lh.gdb oraz bazę z danymi. Używając klienta FlameRobin stwierdzam, że
wygląda jak z Waszego serwera, a jednak LHFK nie chce współpracować. Już
przy próbie podania ścieżki dostępu do lh.gdb pojawia się błąd
(załącznik). Oczywiście wykluczam:
1.
Kod:
root@tytanium:/tmp/lh# ls -alu
razem 33652
drwxr-xr-x  2 firebird firebird     4096 2010-06-19 22:21 .
drwxrwxrwt 22 root     root         4096 2010-06-20 14:08 ..
-rw-------  1 firebird firebird 33669120 2010-06-19 22:03 lh_Demo4.fdb
-rw-------  1 firebird firebird   737280 2010-06-19 22:20 lh.gdb


2.
Kod:
root@tytanium:/tmp/lh# ps aux|grep firebird
firebird 20403  0.0  0.0  27340  1464 ?        S    Jun19
0:00 /usr/lib/firebird/2.1/bin/fbguard -f
-p /var/run/firebird/2.1/fbserver.pid
firebird 20404  0.0  0.2 111416  6416 ?        Sl   Jun19
0:00 /usr/lib/firebird/2.1/bin/fbserver


3.
Skanowałem porty i 3050 jest otwarty, tak jak na dotychczasowym
serwerze. Ponadto FlameRobin łączy się po sieci i można pracować na
bazie danych.

Proszę o pomoc w rozwiązaniu tego problemu, bo wcześniej czy później
większość Waszych klientów będzie przechodziła na systemy 64 bitowe i po
co mają się niepotrzebnie denerwować.
W wersji linuxowej może nie ma potrzeby dołączania serwera bazodanowego,
bo większość dystrybucji zawiera takowy. Powinny wystarczyć jedynie
drobne zmiany, żeby LHFK mógł korzystać z rozwiązań systemowych. A
użytkownicy będą mieli jeszcze jedną zaletę - szybką aktualizację w
przypadku wykrycia błędu w systemie bazodanowym.

Gdyby jeszcze można było korzystać z PostgreSQL..... :)
 
   
ximian 

Wiek: 34
Dołączył: 14 Sty 2008
Posty: 16
Skąd: Jaworzno
Wysłany: 2011-07-09, 17:50   

Udało się coś zdziałać z nowszą wersją Firebirda? Migracja na nowszą wersję silnika bazodanowego naprawdę jest takim problemem dla twórców LeftHanda?
 
   
jacek1210

Dołączył: 30 Wrz 2012
Posty: 1
Skąd: Polska
Wysłany: 2012-09-30, 18:34   

Problem jest bardzo poważny: mam kilka innych programów które też potrzebują firebirda, tylko że od 2.1 w górę. Dotąd radziłem sobie tak, że firebird 2.0 ma komendy obu standardów i obsługiwał zarówno LHMK (FB 1.5) jak i inne programy (FB 2.1). Ale teraz te inne programy zaczynają wymagać FB 2.5 i pewnie zaczną się problemy. Używam LHMK od 3 lat, ale jeżeli szanowni Autorzy nie przepiszą kodu na nowe firebirdy lub nie opiszą instalacji LH na drugiej instancji linuksowego firebirda, to będę zmuszony zrezygnować z LH bo z tych innych programów serwisowych nie mogę zrezygnować. I jeśli pójdzie tak dalej, to liczba użytkowników LH zacznie się zmniejszać w postępie geometrycznym :-?
 
   
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group
Theme Mer created by maxis